MENY

Ebrary doesn't work in old versions of Internet Explorer

If you want to read books in the database Ebrary, you need the latest version of Internet Explorer, or you have to use another browser.

There has been discovered a problem with the database Ebrary: If you use Internet Explorer, Ebrary only works in the latest version, Explorer 11. At UiS, this version is not installed, so here you have to use another browser, such as Firefox or Chrome.

On your private PC, you may use Explorer if you want to, as long as you have updated to the latest version. If you have a Mac, Ebrary works in Safari.

We apologize for any inconvenience, but these are circumstances beyond our control. Please contact the library if you have any questions regarding this.

ebrary logo